Home Website Youtube GitHub

mGear not showing in Maya 2023

import pymel.core

If that returns an error, it’s not installed.

Error: ModuleNotFoundError: file line 1: No module named ‘pymel’

but when i use install ISO i have no option to pick it up.

Is there a manual way to install it? and if, could you plz give me some advice on how to do it properly?

I was having the same problem of the menu not showing up even though pymel was installed.
I just ran the mgear user setup in the script editor and it appeared.

Yes there is no longer an option to install Pymel in Maya. You have to do it manually. You can download Pymel here. Release 1.4.0b1 · LumaPictures/pymel · GitHub

And installation instructions are inside that package in a file called install.rst


More info in this thread: Maya 2024 Looks Promising. Will mGear be available for it like previous versions? - #25 by i3D

Thanks a lot to everybody ;D

im at step 3. where i need to run setup.py but there is no such file:
i have only setup.cfg

Could it be that pymel is installed but the fact that i block all connections for maya via firewall that it isn’t working?
When starting the setup i saw this little message.

When I try to run the “user setup” it tells me the Pymel module is missing

Error: ModuleNotFoundError: file line 3: No module named ‘pymel’

Sorry my advice was for Maya 2024, where you now have to install Pymel manually. I have no idea why it isn’t installed for you in 2023.

That message in the installer means you would need an internet connection to use “pip” to download and installed Pymel.

Don’t follow my advice blindly. I haven’t even tried this yet. I’m still using Maya 2020 and 2022. :slight_smile:

I reinstalled Maya and now i don’t get the error for missing Pymel anymore. But:

A line 217 error no ;( any ideas`?
I also tried setting it up manually by using userSetup.py but im getting the same error

Have you tried to see if it was successful? Maybe mGear is installed already.

If that “Installation Complete” message ran, then it seems like the drag_n-drop_install.py script ran successfully. That’s the last line in that function.

The error might be from del myTempEDPF which is… what? Maya’s wrapper for dragging Python files?

(Just guessing. I install mGear through Maya.env.)

Try restarting Maya and maybe mGear is installed.

  1. See if you get any mGear errors when you start Maya.
  2. Check if it shows up in the menu.
  3. Try running import mgear and see if you get an error. (If you don’t get an error, then it is installed, but you are still experiencing the missing menu problem.)

No error no menu
this error when running import mgear

sry i found this same error from befor when starting maya
// Error: RuntimeError: file C:\Program Files\Autodesk\Maya2023\Python\lib\site-packages\pymel\internal\pmcmds.py line 217: deleteUI: Object ‘mGear’ not found.

here the full log in a .txt file . i placed it on google drive

I deleted everything and dragged the py again and now i didn’t get the import mgear error but still missing the menu.
plugin was also active already not like last time where i had to active it manually but still got the line217 error.

Oh I see. I searched that error. It’s discussed in this thread: Mgear Don"t show up - #6 by Miquel

Miquel said there is a fix, but it isn’t in the latest release yet. You would have to get the latest code directly from Github.

It looks like you accidentally put a space before the command.

so I get 4.0.19 from here?

After installation, I had to run userSetup.py and then it appeared ;D

GG boys!

If anybody have this problem, try this method, its work for me:
In script editor type these two lines:
from mgear import synoptic
if the picker shows up, you can grab and put the 2 line to your custom shelf, and it will work. :slight_smile:
Sorry for my bad english :smiley:

Ok I thought the problem was fixed but it was only temporary.
Every time i open Maya i have to repeatedly drag and drop the useeSetup.py to make the menu appear.

from mgear import synoptic

started the picker but it didn’t work. only after using useeSetup.py the full functionality of the tool was available again.

Sorry I don’t know how to help you. What “userSetup.py” are you referring to? Where is this file from?

The one .py script that gets extracted to the folder: Documents\maya\modules\scripts

This morning dragging it in didn’t work so I pulled it into the editor and ran it that way and it worked …

It told me following error at first

Warning: Module userSetup does not contain drop function: onMayaDroppedPythonFile

Hello, jumping on this thread because Im also having issues installing.

OS - Windows 10
Maya 2023
Drag and Drop installation
mgear solver shows up in plugin manager

but in script editor I get this error:
file -f -new;
// untitled
commandPort -securityWarning -name commandportDefault;
// Error: line 1: Could not open command port b’commandportDefault’ because that name is in use.
onSetCurrentLayout “Maya Classic”;

pymel.core : Updating pymel with pre-loaded plugins: GPUBuiltInDeformer, cacheEvaluator, deformerEvaluator, renderSetup

// Error: deleteUI: Object ‘mGear’ not found.
// # Traceback (most recent call last):
// # File “C:/Users/kylev/OneDrive/Documents/maya/modules/scripts/userSetup.py”, line 25, in mGear_menu_loader
// # mgear.install()
// # File “C:\Users\kylev\OneDrive\Documents\maya\modules\scripts\mgear_init_.py”, line 35, in install
// # self.menu_id = menu.create()
// # File “C:\Users\kylev\OneDrive\Documents\maya\modules\scripts\mgear\menu.py”, line 19, in create
// # pm.deleteUI(menuId)
// # File “C:\Program Files\Autodesk\Maya2023\Python\lib\site-packages\pymel\internal\pmcmds.py”, line 217, in deleteUI_wrapped
// # res = new_cmd(*new_args, **new_kwargs)
// # RuntimeError: deleteUI: Object ‘mGear’ not found.

Regarding the “userSetup.py ” I found a solution where I do not simply drag the file in, I run the script from the shelf twice and then the Menu appears and everything is working properly.