Home Website Youtube GitHub

mGear not showing in Maya 2023

Hi there!

I got into mGear (v4.0.9) earlier in the year when testing out rigging solutions for a test short I was making in Maya 2020. I loved it and am starting the rigging for a longer project now, but have since upgraded to Maya 2023.

I’m having an issue though where the mGear dropdown doesn’t load in 2023 when I open Maya, but it did in 2020 (and still does). All the plugins are there in the plug in manager and are all supposedly loaded but the menu item won’t appear.
I’ve gone through some older threads about a similar thing in 2022 and I have made sure pyMel is installed (by both installing it after installing 2023, which did nothing and then a clean install of 2023 with pyMel installed from the outset and still it did nothing.)

I’m not overly technical with python etc, but the only way I can seem to actually load it is by dragging and dropping the userSetup.py file from the module / scripts folder into the Maya script editor and running that. It appears after that, but I worry that I would need to run that everytime and if I forgot to before opening a scene I’m going to get the rig freaking out - that happened to me a few times when working at Megalis and I loaded rigs without having mGear enabled, the results were not pretty haha!!

Wondering if anyone has any idea what might be stopping it from auto loading, I think I’ve done everything by the book. Any help would be really appreciated!

Thanks in advance :slight_smile:

Start a clean maya and check the Output Window (windows → output window) and script editor for any errors. Do you see any?
Turn on Display Stack Trace, and Show line Numbers in Errors in the Script Editor’s History menu and try to run import mgear what is the output?

mGear 4.x is python3 as is Maya 2023. It’s likely your Maya 2020 is on an earlier mGear version. Basically for Maya2023 make sure you have Python 3 installed with mGear 4.x.

Hi Alonza, thanks for the reply!

There are no errors in either the output window or script editor pertaining to Mgear (just a megascan plugin issue and the wiremesh plugin)

Running the command import mgear (python, not MEL, I assume?) does nothing. The command sits in the script editor in 2023 with no errors but nothing happening either.
It is 100% the same version I have installed in both Maya 2020 & 2023, which is mGear 4.0.9, as it’s the only one I’ve ever downloaded. The ‘about’ section of mGear in 2020 confirms that. The only difference is the maya version, 2020 loads it fine, 2023 does not.
I can send screen shots for all the above if needed!

Not sure if that further helps narrow down the cause.

Do you have installed Pymel? it is optional for Maya 2023 but mGear needs it

1 Like

Hi, I´ve just upgraded to Maya 2023, did install de Pymel, the plug-in manager does recognize it, but the menus… the buttons still doesn’t appear

Sorry, first time posting on internet

Hi @Miquel yes, I tried both installing it after having installed 2023 and a clean install. Neither worked unfortunately!

FYI the menu is only visible when on the Rigging menu set. You probably checked, but I say this because your screenshot shows you’re on the Modeling menu set.
F3 is the keyboard shortcut for Rigging menus.

I’m not sure about that. It shows up in every menu set for me.

But I don’t have any answers for why it doesn’t show up, sorry folks. :frowning:

I stand corrected! Not sure why I was sure about that.

As for why menu isn’t loading, if you have pymel and python 3 installed (when using the newer mayas), and the mgear plugin enabled it should definitely show up. Check the script editor and output window for errors.

The’re are any errors, no logs, no warnings, just drag n drop, or the old installing process.
It just looks fine, loaded and autoloaded in the plug-in menu, but still doesn’t appears. =(

Check your installed Python version.

import sys
print (sys.version)

If you are using python 3.0 or higher I don’t know what more to try. If it’s less than 3, that’s your problem.

Also, as an aside, make sure you have these check boxes checked so if an error does pop up it is described in detail.

1 Like

3 posts were split to a new topic: Cvwrap print statement errors

Also still having this issue~ am able to successfully install and enable the plugin but a menu set does not appear. Has anyone found a recent solution to this? (Currently using MacOS Ventura 13.1)

Any solutions so anyone?
We have several Windows PCs where mGear just won’t show up. Using Maya 2022 with Python 3.7.7
Thank you

Hi welcome. Please provide more information.

  • Which method of mGear installation did you use?
  • “several Windows PCs”, does that mean it is working on some of your computers?
  • Is mGear loading properly? import mgear and see if it gives an error. Or is it just the missing menu?
  • Any other info you can think of.

If we can’t figure out a pattern, or a way to reproduce it, we can only guess. I think there was one thread where someone solved it. But it was something to do with their Maya.env setup.

1 Like

it could be an issue with pymel not loading correctly, check the path entry in your enviroment variables.

I have the same issue - menu isn’t showing

Dragdrop installation in fresh 2023.3
3.9.7 (tags/v3.9.7:1016ef3, Aug 30 2021, 20:19:38) [MSC v.1929 64 bit (AMD64)]
Plugin mgear_solvers.mll is listed and loaded

The same version is working in 2020
Menu Set Editor is also not listing mGear

Would it even install if pymel wasn’t installed?
Im 99% sure that i installed it but how could i check for it?

the installed don’t use pymel, but you need pymel to launch mGear after is installed

so is there a way to check if it’s installed? Since the menu isn’t showing up.
Any ideas on what I could do to make it appear?

And its also not showing in the output window as it did in 2020 ;/