Home Youtube GitHub

Slow viewport interaction


#1

Hi,

I was profling some rigs because they were very slow when interacted with and the slowness was the same between difference machines. In the end I disabled “Include controllers in evaluation graph” in Maya’s settings and that magically fixed it. Not sure how it makes a difference but try it if you see the rigs are unusually slow.

Cheers,
Armin


#2

Thanks for the info @Armin_Halac I will check this.

btw: Maya version?


#3

2018.2
Thanks Miquel.


#4

Hello @Armin_Halac

Could you try another Maya 2018 update. On update 2018.3 there is this bug fix which might explain your issue
MAYA-89203
Slowness due to controllers when invisibility evaluator is enabled


#5

Hey Jerome,

I will try that as soon as I can and post an update here. Thanks for the help.


#6

@Armin_Halac

I have done some test with 2018.4 but not sure if I can reproduce the issue.

Just in case:

Do you have the heads-up display for evaluation? can you check the status of EM state?

image

is ready when the slowness or Rebuild Required?

Because the first interaction until is ready affects the manipulation. Also if the control has keyframes.

I was talking about it here:

Just asking to be sure it is not the same issue.

Thanks for checking this!

Cheers,
Miquel


#7

Hey guys,
Upgrading to 2018.4 fixed the issue. The framerate is pretty damn good now.
@Miquel I already updated before I saw your message so I can’t go back and check what the EM State value was before. This is what it looks like now in 2018.4:
image

Thanks for the help!


#8

You are welcome! I am glad was fixed by updating maya :slight_smile: