Home Website Youtube GitHub

[SOLVED] Export skin error with mGear4.0.3 in Maya 2022

Hi. I get this error when trying to export a skin from meshes with which the maya deformer export works well (only one deformer on them, basic skinClusters):

# Error: RuntimeError: file C:\Users\Quentin\maya\2022\modules\scripts\mgear\core\skin.py line 146: (kInvalidParameter): Object is incompatible with this method # 

=> no file at all is created.
Any tips ?
The rest of mGear (guides, building, picker…) seems to work fine (but its SDK Manager that cannot open)

1 Like

Can you give some more info?

  • What do you have selected when you try to run this? (Multiple objects? Shape or transform?)
  • What exactly are you running? A script, or from the menu?
  • Do you have multiple shape nodes under one transform? As far as I know, this isn’t supported and will fail. You should instead combine your meshes so you only have one shape node.
  • Also I would check to make sure your shapes are not instances. I haven’t tested, but I bet that would fail too.
  • Can you maybe show a screenshot of your mesh in the outliner (including the shapes please) or the skinCluster settings from the attribute editor.

Multiple shape nodes fails, but I get a different error in Maya 2020. I haven’t tested Maya 2022.

// Error: RuntimeError: file C:\Program Files\Autodesk\Maya2020\Python\lib\site-packages\pymel\internal\pmcmds.py line 130: The skinCluster does not deform the selected component(s) //

1 Like

Hi @chrislesage , thanks for the answer.
Alas it doesn’t fit in the multi or instanced shape category.
All my meshes are pretty usual and monoshaped.
Only special thing is that I deformed them from a referenced modeling, so it creates a “*ShapeDeformed” final shape and their original ones are set as “intermediate” of course, but I’ve used that workflow with mGear skinpack and globally in rigging so many times ! (like for years, maybe decades…)
Also, very normal and basic skinCluster (classic linear)


As for the usage, I was selecting the mesh(es) and tried to use mGear > Skin and Weights > Export Skin or Export Skin Pack ASCII …

Does that help ?

Hi again.
I wonder : does the “Rigging / Component Tags: Use component tags for deformation component subsets” option matter for this ?.. (in the Animation settings)
It was ON by default and no Tweak nodes were created neither… That might bother the traditionnal skinning mGear workflow no ?..



Oooookay… so, it must be this component tag thing that were activated…
Copying back and forth my skinweights while switching it off in the meantime (and enabling Tweak nodes) seemed to fix it…

Sorry for bothering! ^^’


No bother, that’s good for everyone to know, thanks!

I haven’t tried that feature yet.


Yeah, I should have thought of it earlier since it is actually bothering other part of our deformer workflow!.. (I supposed I switched it off for that reason actually…)
Anyway. Good to have a proper reason for these “bugs” ! ^^’

Thank you Quentin for this tips, this was super helpful.
It’s important to mentioned that the option must be unchecked before the skin is created.

Luckily you can use the Maya default export skin option to save your work, then kill the bind, uncheck the box, reimport the saved skin then export it using the mGear Tool…


So the solution is reskinning with Tweaks activated?
I don’t see any difference with or without this setting.
Still getting the same error:

Error: RuntimeError: file C:\Users\Marko\Documents\maya\modules\scripts\mgear\core\skin.py line 146: (kInvalidParameter): Object is incompatible with this method

I have tested it with imported or referenced geo the result was the same.
image tried all 3 methods
image tried all at once or separately

I just want to say, thank god for this thread!
I have been setting up a new workstation I got from work. So naturally I am installing the latest software for everything I use. Went from Maya 2023 to 2024, and mGear 4.0 to 4.2.
Trying to build a rig I created last year, and discover the line 146 error above. Nearly freaking out, I find this thread. Vaguely remembering having to change the preferences mentioned above.

I set mine like so, and restarted Maya and the error went away. Thank you!