Website Youtube GitHub

mGear Framework Forum

Space Switching Crashes After Opening AttributeEditor

Hello!

I’m working on a creature rig, and I encountered a very strange thing.

I’m using leg_3jnt_01 component on its foot(legBack in the image), and using space switching(IK reference array) on the component.

I opened the attribute editor to see the parent constraint node used in space switching (legBack_L0_ik_cns_parentConstraint1 in the image).

After that, switching the space changed the position of the foot.

I think it’s because range of the target weight value in the parent constraint node was changed by opening the Attribute Editor

Because if I assign very large value on the weight, it works well.

my mgear version is 3.6.0

I sheared this problem with my co-workers and checked it in multiple maya versions(2018.5 2020.2 2020.3) and multiple PCs, but the result was the same.

I tried same test on different components(arm2jnt_01,leg_2jnt_01,etc) and confirmed that the same problem occurs.

Though I think It’s maya internal issue, I’m very glad if I can have good solution to this.

Thank you

Parent Constraints have an “Update” button which neutralizes any offsets in all the targets.

Set your space switch to the good position, and then hit Update. Then try to switch back to the bad position. Does it fix this problem? (It might not.)

1 Like

Thank you very much for your quick reply!

I tried it, but the foot was placed at crazy position

I think not position information but weight value range is changed from 0~1 to 0~9223372036854775808(maximum value in maya)

It works well by making the weight value larger , so that’s what I’m dealing with for now.