Home Youtube GitHub

Synoptic's IK/FK blend stopped working


#1

So here’s the thing, I made custom synoptic for an asset (made it using biped template). Everything works when I make a fresh rig from the Shifter (IK/FK blends perfectly and vice versa). Doesn’t work in a finished rig file for some reason. Everything has the same name, I didn’t change much, only added things in the hierarchy. Could this be the case for the issue?

EDIT: Found the issue -> “Optimize Scene Size” clears transforms and disables it. Is there a way to bring back those transforms to finished scene?


#2

“Bring back”? No, I don’t think that is possible, without rebuilding your rig, or opening an older backup.

As a general rule, never run “Optimize Scene Size” on a rig. Some of the individual options in that window are safe, but the whole default settings are not.

Here are some safe things to delete. ngSkin and hyperView nodes can really make a scene much bigger.

import pymel.core as pm
pm.delete(pm.ls(type='hyperView'))
pm.delete(pm.ls(type='ngSkinLayerData'))
pm.delete(pm.ls(type='nodeGraphEditorInfo'))
pm.delete(pm.ls(type='createColorSet'))

Also, if you are building your guide file over and over multiple times, it is possible that “controller” nodes are being added each time, and your scene size will grow. I delete previous controller nodes each time I build my guide. I wrote about that here. 2 Shifter Tips: Files sizes and proxy attributes


#3

Big thanks for the info!