Home Website Youtube GitHub

Animation layers problem (Maya Bug)

In maya 2020.4 when I create animation layers than I can’t move control. Its can fix that?

I am also facing the same problem… translation and scaling seems fine, but I can’t rotate the controls, happens not on all but some of the controls

Maya 2020.4
mGear 3.6

I updated to mGear 3.7.9 and the problem still there.

I tried doing the same thing on Maya 2019.1, so far doesn’t seem to have any problem on Maya 2019.1

I am not sure that is a mGear problem.
Can you try with another rig (not mGear) or a simple object?
I have found other similar issues in Maya 2020

Hi Miquel, thanks for checking on this,

I tried with simple object and another rig >>

(first part of the video showing a cube and circle nurbs control, second part of the video showing Azri rig from www.gameanim.com, both seems to work with animation layer, third part is my rig with mGear, rotation works until i add it to the animation layer)

I also tried on Default Maya configurations and default mGear Shifter’s Biped Template

(video showing the rig built with mGear Shifter’s Biped Template in default maya configurations, some controls works but some couldn’t rotate after added to an animation layer)

It could possibly be a Maya issue, or even just on my machine, i also haven’t test this on the earlier Maya 2020 versions yet.

Hello @miica I have tried on my machine and can’t reproduce the error.
The only difference is that I am using Maya 2020.3

can you try to turn on/off some of these attributes in the evaluation manager?

for example in 2020.3 the mouse middle click the virtual slider in a channel will not work with this option active when the channel has 2 keyframes :frowning:

2 Likes

Thanks Miquel! turning off that option did the trick (Windows → General Editors → Evaluation Toolkit → 01) Modes → Advanced → Uncheck Manipulation)

All working now :slight_smile:

2 Likes

The reason why is happening with mGear rigs, is because we are using the controller tags. That is indeed the correct way to mark your controllers in Maya. So this is a Maya bug :frowning:
I hope this is fixed in the next Maya version. :stuck_out_tongue:

3 Likes

Btw if your evaluation toolkit won’t open (it’ll just give an error message) and you’re using SHAPES, here is the fix for that:

"

  1. In the SHAPES installation folder go to SHAPES/scripts/pySHAPES and rename the folder commands to uiCmds.
  2. In the file SHAPES/scripts/pySHAPES/ui/rename.py change line12 to: from pySHAPES.uiCmds.targetList import rename

That’s it."