Website Youtube GitHub

mGear Framework Forum

Crash opening scene with baked controls

Hi!

I made a rig following steps of the mgear youtube channel. Everything works great but when I save the scene with edited and baked controls I can not open it again, Maya crashes while opening.

I think it is the controls problem because I deleted everything but the controllers_org group, save and open It.

I also tried to export and import them, also crashes. I don’t know if there is a way to print the Stack Trace so I can see where the problem is.

If I bake controls without editing the control shapes, it doesn’t crash.

Thanks a lot.

Hi Andrew.

Are you using Proxy Attributes? Does this thread seem like it addresses your issue?

2 Likes

you can try opening your file with maya 2018

1 Like

I had the same issue using Maya 2020.1… you can recover the file by opening with 2018, as @c17vfx said.
I think latest Maya 2020 update fixes up the issue, but i kept myself using Maya 2019, which is by far more stable and reliable and didn’t check if this is 100% fixed.

Cheers.

2 Likes

Hi! Thanks a lot. I did this:

And now I have recovered everything.
That’s right, It was because of the Proxy Attributes. I’ve seen Maya has solved this bug in the latest updates. I will keep it turned off, so animators won’t have any problem.

2 Likes

update maya 2020.2 the problem persists

Thanks for the update!

Side note: I was wondering if that Spiderverse rig crash was related to this. But I just checked and I don’t see any -uap flags in that file.

I was cheering a bit with this file Wayne, Batman Rig on maya 2020.2
and the lock file, no open more

to wait for another update…

that sucks!! 8-( I rigged and animated the whole thing using Maya 2019… I tried 2020 and got me so many errors and also slower performance in general…that made me stick to 2019.

1 Like

totally agree returning to maya 2019 :bat: