Home Website Youtube GitHub

mGear Maya work files crash when opening up

For the second time since I started my new project, my mGear work files don’t open anymore and crash as soon as I open them, forcing me to revert back several versions. This is very annoying and scary as I was nearly done with my rig.

Currently I am using Maya 2019.2 and mGear 4.03 on Windows.

I did a bit of digging and found several threads that seem to be similar so I wil post them below as reference for the discussion and hopefully we will be able to find a solution.

  • some threads are talking about incompatibility with Maya versions,

  • others are talking about Proxy Attributes. I have no clue what Proxy Attributes are so I doubt I would have used them. Here is some documentation about Proxy Attributes I just found PressReader.com - Digital Newspaper & Magazine Subscriptions

  • some of the solutions involve using .ma files rather than .mb files in order to edit the files or if you still have a file open, to deleting everything under the controllers_org allowed me to export and save the guide”. That solution doesn’t please me much as I spend quite a lot of time customizing my controls :confused:

I am really worried to open any old file since the issue feels like it is propagating to other files so I guess I will have to try to install a different version of Maya. Hopefully I won’t have to uninsall Maya 2019 which I need for some old projects :confused:

Reading through the threads, I don’t seem to see a pattern in the Maya version used.

People using various versions of Maya 2019 and 2020 are facing the same issue and often the solution seem to be going back to Maya 2018 :confused:

Now few times the controllers_org group was mentionned as possible culprit and I am starting to believe in that hypothesis.

Last week, I had similar issues and trying to clean my mGear files, I deleted everything in the scene except the guide group and tried to export that group but the resulting files were also crashing when opening so I eventually restarted my rig from scratch.

Having learnt my lesson the hard way, the way I am working right now, is to have one Maya session open in which I do my rigging work, and as soon as I save, I open the saved file in a second Maya session to see if that save is corrupted or not.

You guessed it, it is a dreadful workflow and still hasn’t prevented me from creating crashing files like today but at least I still have one session open from which I can do tests!

So in this work file today, I tested the controllers_org hypothesis and deleted all the children of the group and guess what… it worked. The saved file open up!

Now I was hoping to backup the original controllers_org group as a .ma file and at some stage reimport it since I did a fair amount of customisation with my controls but nope, that export file crashes Maya immediately when loading!

I was hoping to troubleshoot that controllers_org export but things are not that simple though since Maya has still exported the guides in the same file.

Anyway so on my side, the issue seems to be with the controllers_org group. I hope it helps anyone.

Make sure this was checked off in your guide.

1 Like

Ah I see, yes it was on by default as I don’t remember setting this up.

image

Strangely enough, it only started corrupting my Maya files today and last week.

Here is a screenshot from a file from yesterday and that one still opens up

Thanks Chris, now I need to find a way to rescue my old files.

Ah, now what I am remembering doing today was to remove the joint from the control_01 of both the :

Global_C0_root and the GlobalOffset_C0_root but their respective controlBuffers were still present in the controllers_org group!

image

image

So possibly this is the actual issue in that file!

Yeah I ended up with a couple rigs with that turned on accidentally too. I’m going to add a pre Python script to turn it off in my rig builds.

Also bear in mind, if you uncheck that option, you still need to rebuild your rig. But the proxy attributes might still be on the controlBuffer transforms. (I don’t know.) So after you build with that option turned off, you might have to extract all your controls again. Or extract at least the problem ones you if you can isolate them.

1 Like