Home Website Youtube GitHub

Maya 2020.2 crash when opening rig

Hi ! :grinning:

I’m using mGear 3.6.0 on a Maya 2020.2. I started working on a rig and after some basic work (skin with NgSkinTool with custom nodes baked) I can’t open my animation scene anymore… It loads, freezes and instantly crash.

What’s strange is that I worked a few hours on this animation scene with this rig version before…

I found some answers about my interrogations here: http://forum.mgear-framework.com/t/crash-opening-scene-with-baked-controls/1531: Maya 2020.2 is not stable.

To test this I opened my scene in Maya 2018 and Maya 2019: the animation scene opens and loads the rig without errors…

I know that the problem comes from Maya but is there something mGear dev can do to prevent the 2020.2 instability ? I’m a student and the school don’t really want to rollback to 2019…

Hey @Augu
Great news! Maya 2020.3 has been released

So HOPEFULLY, this resolves the issue you are experiencing. But the only way to be sure is to give it a try. Let us know how you get on.


1 Like

It’s funny because we had similar issues with Maya 2019.0: started working on characters in mGear 3.4, no issues at all, and one day Maya decides to start crashing. Installing Maya 2019.3 solved the issue for us. Seeing this when I was starting to consider switching to 2020 at some (near) point in the future does not give me a lot of hope from the Autodesk side.

@Rafael, are you aware if there’s been a poll in the forums regarding the Maya + mGear version that people are running?

@iker.mozos Hey, no I am not. But that would be great information to have on a quarterly basis.

I would hope they would be as up to date as possible with mgear. But I know shows like to “lock in” when they can.

@Miquel Should we have a poll?

@Rafael Yes, good idea. I will check if is possible to do it here or use another service to do the poll

I have some animators on Windows / mGear 3.6 / Maya 2019.3.1 reporting lots of crashes when scrubbing. They are suspecting the spring nodes, but I’m going to send them a with/without test later on.

Some polls would be great. So many different configurations in OS, Maya version, and mGear version.

Do you know if they are using GPU override? I have found lots of crashes in the past. But it was in Maya

We are sticking to Maya 2019.3 (some people using 3.1) and mGear 3.4. In the past I noticed crashes when using Parallel evaluation and timeline caching. But I’ve been using it lately with and without spring nodes and it’s been fine for the most part. I get Maya freezing from time to time (forcing me to restart), but I’m not sure if it’s related to Parallel/caching/spring nodes, because it also happened on DG.

What I found in the past is some animators installing mGear 3.5, and the rig built in 3.4 not opening properly, or making Maya crash. It’s been tricky to do proper testing because everyone has their plate full. Plus we have half the animation team working in Windows, and the other half, in MacOS, but issues do not seem tied to a specific OS.

In terms of mGear rigging, we are not doing any crazy overrides, as we are using out-of-the-box Shifter guides, plus eyes generated by Facial Rigger.

1 Like

My group rolledback to 2019.2 and we have no issues right now.
Another group of my class switched to 2020.3 as you recommended and have no issue either.
We both have only a biped template running and for me some basic ctrls for the facial.

We have these new setups since 3 days but crashes can come at anytime like @iker.mozos said.

Animators got back to me:

“I turned off GPU override and haven’t had a Maya freeze yet! Frame rate seems to be 24 fps with it on and off. Rig doesn’t seem to slow down.”

(I think their playback is capped at real-time which is why they thought it didn’t slow down. But this is good news. It’s still fast enough for them, even with GPU override off.)

1 Like

I’m in 2020.4 and just built a basic biped rig. I went to open it a few minutes later and Maya repeatedly crashes at 64%. I am seeing this with another MGear asset as well.

Hey Ryan,

Did you build the rig using proxy attributes? I seem to recall that being one of the causes of crashes when opening files too.

Does it crash consistently every time?

If you did use proxy attrs (in the guide settings), would you be willing to try without, and see if that solves the problem?


have you tried to import your scene to a fresh maya scene? I had an issue where that crash happend and doing that can help solve it

1 Like

I did add proxy attributes after the build. The odd thing is it opened just fin an hour later.

Maybe someone else has had better luck, or has tips. I just super don’t recommend proxy attrs. They make the graph editor very messy too.

I’m going to try that. This rig crashes maya like 80% of the time

Hello !

Sorry to revive an old thread but I have been experiencing an issue with scenes crashing upon loading too. I’m also linking to two other threads that are highlighting crashes as well with some different scenarios which are:

My reason for reviving is because I’m hoping this will provide some help to fixing the problem but it raised another question for me.

While I would find it strange that this would cause the problem, I experienced this type of crash where I could not even clean my scene and open up the guides without maya crashing, I would need to rollback the file and start over as the scene would corrupt over time (it would work and reopen for a while and then crash constantly after some time)

I managed to export the guides and reopen them without a crash after deleting the controllers buffer (everything under the controllers_org) folder. I don’t have a clue why this would be the reason as the crashes kept on happening in other scenes where the guides have been removed.

Anyone have an insight as to why and how this would have fixed the issue?

tldr; deleting everything under the controllers_org allowed me to export and save the guide, and removed crashes.

mGear 3.6.0 - Maya 2020.3

Thanks for the assistance

The first big question: Were you using proxy attributes?

As a possible insight: controlBuffer sticking around when outside of hierarchy of export selected - #6 by chrislesage

In that thread, I learned that the control buffers are instances. So there might be some bugged out connection between those nodes. Even if you were using proxy attributes, but stopped, some of those buffer nodes might still have those connections stored. Or maybe you found some weird bug related to instances and reference edits or if a non-deletable node was parented under an instance or… something.

If you want to get scientific and really solve it, I’d delete half of the buffers and test. Then delete the other half and test. Ignore any half that doesn’t crash. And keep subdividing the crashing half until you narrow down on a problematic node. After 3 to 5 subdivisions, if it doesn’t stop crashing on any tests, maybe it is all of them. But maybe it was a single node.