Home Website Youtube GitHub

Maya crashing when loading mGear file

Hi! Is anyone experienced major issues using Maya 2020.1?

I have been having problems loading mgear files containing guides. Comes to a point that Maya is not able to load the file (even all the incremental files before certain point), vanishing.…not even errors…literally disappearing when loading the file.
However, the files can be open in Maya 2018 and recovered!!!..but once saved again in Maya 2020 gets corrupted.
It happened to a friend of mine too, also in 2020. We were able to conclude that having the guide caused the problem, but is not very consistent, as is not 100% reproducible.

It is driving me crazy! Any help will be much appreciated.


I’m finding pausing the viewport before loading prevents this from happening.

1 Like

thanks! I tried, but still crashing…

loads up to 54%…then holds there for a few seconds before blowing up…leaving no trace…


I’d like to bump this, and see if you found any solution? I have this same problem using mgear 3.5.1 and mgear 3.6 in maya 2020.1

I’m not sure if this is the problem, but it seems if I load a file containing controlBuffers that worked in 3.0.3 and use buildFromSelection and save. That file crashes if you then close and try to open the file again.

Hello @Alicia can you check if is the same issue from this thread?

btw: I will recommend using 2020.3 this other issue was fixed in 2020.3