Home Website Youtube GitHub

Biped Template Loading Errors in Maya 2023?

Hello! New to mgear, using Maya 2023 and MGear 4.0.9. I’m able to load and build individual components (nice!), but when I tried to load a biped template such as “biped template, Y-Up”, the progress bar on the load quickly gets stuck and I get the pymel error below.

Could anyone point me in the right direction to get around this?


`file -f -new;
// untitled
0.35119664200465195 time elapsed running draw_guide

Error: RuntimeError: file /Applications/Autodesk/maya2023/Maya.app/Contents/Frameworks/Python.framework/Versions/Current/lib/python3.9/site-packages/pymel/internal/pmcmds.py line 217: Unable to create/find dependency node.

file -f -new;
// untitled

There are a few threads about this. Can you check in your plugin settings and see if the mgear plugins are loaded? From answers in these threads, it sounds like it is related to the installation not finding the plugins correctly.

If you are on MacOS, make sure you run the security quarantine command that is listed on the download page:

sudo xattr -r -d com.apple.quarantine /PATH/TO/THE/MGEAR/SOLVERS/DIRECTORY/

1 Like

Thank you - Problem Solved!

Yep, it was as simple as making sure the solvers were loaded in my plug in manager!

1 Like